Universal Access To All Knowledge
Home Donate | Store | Blog | FAQ | Jobs | Volunteer Positions | Contact | Bios | Forums | Projects | Terms, Privacy, & Copyright
Search: Advanced Search
Anonymous User (login or join us)
Upload

Reply to this post | Go Back
View Post

Poster: 2muchtv Date: May 2, 2004 9:21am
Forum: feature_films Subject: a little help with QT?

A wintel idiot (me) just can't seem to get the movies to play in the feature films section. I can get the films on other sections of the Archive to play in Real and WinMedia, and I can download and play - but would rather not. Would sure like to just click the stream link and watch the film. QT does work OK for me on other sites, however, and I have viewed QT streaming content on other websites.

It's a 500 MHz PC, Win 98 SE, 128 MB ram, on-board agp video chip with 8 MB shared RAM, cable modem (comcast), running Zone Alarm free version, (QT internet access permited) and NAV for 98.

I uninstalled what ever version I had and went to Apple and downloaded and installed the newest version, and set all the player and QT prefs to "default."

Restarted, no play. Check Apple help and the message boards here, and didn't see anything... The QT logo starts, the play bar comes up, the "connecting" dialogue appears, the play button turns to a pause button and the seek bar starts moving. Sound often starts right away, but no matter how long I wait, no picture.

Any suggestions?

Reply to this post
Reply [edit]

Poster: rgs_uk Date: May 2, 2004 1:39pm
Forum: feature_films Subject: Re: a little help with QT?

My suggestion is that sites stop offering Quicktime :-D I don't think Mac users realise what a total pain in the ass it is on a PC and how badly it performs.

VideoLan is the best player for Quicktime I've found and it works with the clips on archive.org (but I haven't managed to stream them). Quicktime Alternative is another (um) alternative.

Reply to this post
Reply [edit]

Poster: uniQ Date: May 2, 2004 2:27pm
Forum: feature_films Subject: Re: a little help with QT?

Do you have a router/hardware firewall? If so you'll probably need to forward ports there. MPlayer is a good alternative to everything. My absolute best advice is: Buy a semi old Mac (I have NEVER gotten QuickTrash to work in Windows), or download the MPEG/AVI files and play locally.

Reply to this post
Reply [edit]

Poster: Administrator, Curator, or Staffsimon c Date: May 2, 2004 2:33pm
Forum: feature_films Subject: Re: a little help with QT?

I didn't realize that QuickTime uses 'strange' ports for streaming that may be blocked as default with many firewalls, that's the problem I have from some locations, I think.

Here's a random university website with more info:

http://web.brandeis.edu/pages/view/ITS/UsingQuickTimeStreamingFiles

--

Q. Can I access ANY Quicktime movie?

Check to see that you can access any streaming movie by opening the Quicktime Player and clicking Edit > Preferences > Quicktime preferences > Streaming transport. Click the Auto Configure button. Quicktime should confirm that it can use UDP/RTSP port 554. If it switches to http:// port 80, then you are most likely behind a firewall, which likely means that a firewall is configured to block Quicktime streaming files.

Q. How do I tell my firewall to allow streaming files?

The firewall issue is a tricky one. If you have a cable/DSL modem and a router with NAT firewall:

1. Open the Web-based interface for the router
2. Select Advanced and choose "Port forwarding" (wording may differ for your router)
3. Open port 554 for RTSP/TCP data
4. Open ports 6970 through 6999 (inclusive) for RTP/UDP data.

Consult your router's documentation for specific instructions on configuring port forwarding.

--

Useful!
s.

Reply to this post
Reply

Poster: 2muchtv Date: May 3, 2004 12:33am
Forum: feature_films Subject: Re: a little help with QT?

Thanks to all for the replies. Some more info to help me and maybe others get streaming going:

I don't use a network address translation router or a hardware firewall here at home. I have the multiple IP service from comcast, so each of my PCs has it's own IP addy from the ISP.

When I checked the streaming transport panel I was set at auto detect, but I went ahead and specified port 554 to see what would happen. Same outcome.

The Zone Alarm UI shows QT is permitted, and the Zone Alarm system tray graphic shows connection activity, and as I mentioned, sound comes through right away.

Since I'm getting a connection and playing sound, I was wondering if there is a video codec or other compatability issue? I know the IA always uses the most open source technology possible for each offering, and sometimes the OTS client end apps are a little behind the curve on that.

Can ANYBODY out there get streaming on a PC using QT, and if so, (as Eric Idle once said) "What's it like?" :-)

Reply to this post
Reply [edit]

Poster: A/V Geek Skip Date: May 3, 2004 12:58am
Forum: feature_films Subject: Re: a little help with QT?

I can stream QT files on my PC.

I'm running XP with the latest Internet Explorer.

Skip

Reply to this post
Reply

Poster: 2muchtv Date: May 3, 2004 1:54am
Forum: feature_films Subject: Re: a little help with QT?

Do you think it's a media threads issue? Win98-2K one thread, XP multithread? Could the sound codec blow out the video in the open source platform media streamer IA uses? TIA

Reply to this post
Reply [edit]

Poster: Administrator, Curator, or Staffsimon c Date: May 3, 2004 2:13am
Forum: feature_films Subject: Re: a little help with QT?

It's also working for me (Windows 2000, Mozilla 1.6, QuickTime 6.4 plug-in.)

s!

Terms of Use (10 Mar 2001)